[plumi-discuss] embed widget issues with IE

anna at engagemedia.org anna at engagemedia.org
Tue Jan 6 13:42:51 EST 2009


Further to this I get a strange problem when viewing a video from 
EngageMedia.org using the new FlowPlayer embed tag pasted into my 
Wordpress blog:

http://anna.sagaponic.org/?p=71

My browser loads the page, then the status bar reads "Read 
www.engagemedia.org" and I cannot access elements of the page (can't 
click on buttons).

Could this be related?

Cheers,
Anna

anna at engagemedia.org wrote:
> Heya,
>
> I added the flash object tag to a plain HTML page to check, and it 
> renders fine for me in Firefox 3.0.5 on Mac OS X.
> http://files.engagemedia.org/
>
> I'm not sure we are experiencing the same problem here Andrew, however 
> I am pasting in some info on the old object tag versus the new to see 
> if anyone can spot any potential issues in any case.
>
> Old tag:
>
> <object type="application/x-shockwave-flash" 
> data="http://prod-flv.engagemedia.org/FlowPlayer.swf" width="320" 
> height="263" id="FlowPlayer">
> <param name="allowScriptAccess" value="always" />
> <param name="movie" value="FlowPlayer.swf" />
> <param name="quality" value="high" />
> <param name="scale" value="noScale" />
> <param name="wmode" value="transparent" />
> <param name="flashvars" value="config={splashImageFile: 
> 'flash_splash.jpg', videoFile: 
> 'oceanianewsreal/videos/asian-megacity.flv', baseURL: 
> 'http://prod-flv.engagemedia.org/', autoPlay: false , autoBuffering: 
> false, loop:false, fullScreenScriptURL: 
> 'http://prod-flv.engagemedia.org//fullscreen.js'} " /></object>
>
> New tag:
>
> <object type="application/x-shockwave-flash" 
> data="http://prod-flv.engagemedia.org/FlowPlayer.swf"
> width="320" height="263" id="FlowPlayer">
> <param name="allowScriptAccess" value="always" />
> <param name="movie" 
> value="http://prod-flv.engagemedia.org/FlowPlayer.swf" />
> <param name="quality" value="high" />
> <param name="scale" value="noScale" />
> <param name="wmode" value="transparent" />
> <param name="flashvars" 
> value="config={playList:[{url:'http://www.engagemedia.org/Members//anna/videos/climatecamp-train-lockon.mov/thumbnailImage',type:'jpg',overlayId:'play'},{url:'http://prod-flv.engagemedia.org//anna/videos/climatecamp-train-lockon.flv'}],  
> autoPlay: false , autoBuffering: false, loop:false, 
> fullScreenScriptURL: 'http://prod-flv.engagemedia.org//fullscreen.js' 
> } " />
> </object>
>
> Obviously the playlist Flash variable is different, with a different 
> splash image, as is the handling of the URL. I can't see any problems.
>
> Here's the new embed tag for comparison also:
>
> <embed 
> src="http://prod-flv.engagemedia.org/FlowPlayer.swf?config=%7Bembedded%3Atrue%2CbaseURL%3A%27http%3A%2F%2Fprod%2Dflv%2Eengagemedia%2Eorg%27%2CfullScreenScriptURL%3A%27http%3A%2F%2Fprod%2Dflv%2Eengagemedia%2Eorg%2F%2Ffullscreen%2Ejs%27%2Cloop%3Afalse%2CautoBuffering%3Afalse%2CautoPlay%3Afalse%2CplayList%3A%5B%7BoverlayId%3A%27play%27%2Ctype%3A%27jpg%27%2Curl%3A%27http%3A%2F%2Fwww%2Eengagemedia%2Eorg%2FMembers%2F%2Fanna%2Fvideos%2Fclimatecamp%2Dtrain%2Dlockon%2Emov%2FthumbnailImage%27%7D%2C%7Burl%3A%27http%3A%2F%2Fprod%2Dflv%2Eengagemedia%2Eorg%2F%2Fanna%2Fvideos%2Fclimatecamp%2Dtrain%2Dlockon%2Eflv%27%7D%5D%7D" 
> width="320" height="263" scale="noscale" bgcolor="111111" 
> type="application/x-shockwave-flash" allowScriptAccess="always" 
> allowNetworking="all" 
> pluginspage="http://www.macromedia.com/go/getflashplayer"></embed>
>
> Cheers,
> Anna
>
> anna at engagemedia.org wrote:
>> Hi Andrew,
>>
>> Wondering if you've had a chance to test the embed vs. object? I 
>> tested the object tag on my Wordpress blog and had errors - basically 
>> the page wouldn't display properly, I think the WYSIWYG editor in 
>> Wordpress had trouble dealing with it. However the embed tag worked 
>> fine. Wondering if there is something non-standard going on in the 
>> tag that is making certain browsers / WYSIWYG editors spit the dummy?
>>
>> Would be good to do some more testing of this and post a bug if 
>> necessary.
>>
>> Cheers,
>> Anna
>>
>> anna at engagemedia.org wrote:
>>> Hi Andrew,
>>>
>>> Are you using the <object> tag (under the video) or the <embed> tag 
>>> (click the menu button bottom right corner of the video itself, then 
>>> click "Embed..."). Would be good to try both then let us know.
>>>
>>> Cheers,
>>> Anna
>>>
>>> Andrew Carter wrote:
>>>> Hi there,
>>>>
>>>> I have been trying to embed the plumi widget into a webpage (Plone
>>>> CMS).  It works fine on Firefox but IE 7 doesn't display the widgets.
>>>>
>>>> http://www.permaforesttrust.org.au/apt/student-resources/web-video-knowledge-based-training/bioregions-web-videos 
>>>>
>>>>
>>>> We've tried most of the obvious stuff for embedding videos in plone
>>>> but no success on IE.
>>>>
>>>> http://plone.org/documentation/how-to/embedding-videos-in-kupu
>>>>
>>>> Cheers,
>>>>
>>>> Andrew
>>>>
>>>>
>>>>
>>>>
>>>> 2008/12/5  <discuss-request at lists.plumi.org>:
>>>>  
>>>>> Send Discuss mailing list submissions to
>>>>>        discuss at lists.plumi.org
>>>>>
>>>>> To subscribe or unsubscribe via the World Wide Web, visit
>>>>>        http://lists.plumi.org/listinfo/discuss
>>>>> or, via email, send a message with subject or body 'help' to
>>>>>        discuss-request at lists.plumi.org
>>>>>
>>>>> You can reach the person managing the list at
>>>>>        discuss-owner at lists.plumi.org
>>>>>
>>>>> When replying, please edit your Subject line so it is more specific
>>>>> than "Re: Contents of Discuss digest..."
>>>>>
>>>>>
>>>>> Today's Topics:
>>>>>
>>>>>   1. [Plumi] #205: Error on Saving a New Callout or Editing and
>>>>>      Existing Callout (Plumi)
>>>>>   2. Re: [Plumi] #205: Can't Add or Edit Callouts - Error on
>>>>>      Saving a New Callout or Editing an Existing Callout (was: Error
>>>>>      on Saving a New Callout or Editing and Existing Callout) (Plumi)
>>>>>
>>>>>
>>>>> ---------------------------------------------------------------------- 
>>>>>
>>>>>
>>>>> Message: 1
>>>>> Date: Thu, 04 Dec 2008 04:41:56 -0000
>>>>> From: "Plumi" <trac at plumi.org>
>>>>> Subject: [plumi-discuss] [Plumi] #205: Error on Saving a New Callout
>>>>>        or Editing and Existing Callout
>>>>> Cc: discuss at lists.plumi.org
>>>>> Message-ID: <033.8c8e942f93a619df0a79d94cab0122c9 at plumi.org>
>>>>> Content-Type: text/plain; charset="utf-8"
>>>>>
>>>>> #205: Error on Saving a New Callout or Editing and Existing Callout
>>>>> ----------------------------+----------------------------------------------- 
>>>>>
>>>>>  Reporter:  anna            |       Owner:  andycat
>>>>>     Type:  defect          |      Status:  new
>>>>>  Priority:  critical        |   Milestone:  0.2.2.1
>>>>> Component:  SocialSoftware  |     Version:
>>>>>  Keywords:                  |
>>>>> ----------------------------+----------------------------------------------- 
>>>>>
>>>>>  This error was found by Jose. I checked it, and experienced the same
>>>>>  error.
>>>>>
>>>>>  I just published a Callout:
>>>>>  http://www.engagemedia.org/Members/anna/callouts/call_out.2008-12-03.0367831283/atct_edit 
>>>>>
>>>>>
>>>>>  And received this error:
>>>>>
>>>>>
>>>>>  Site error
>>>>>
>>>>>  This site encountered an error trying to fulfill your request. 
>>>>> The errors
>>>>>  were:
>>>>>
>>>>>  Error Type
>>>>>     NameError
>>>>>  Error Value
>>>>>     global name 'security' is not defined
>>>>>  Request made at
>>>>>     2008/12/04 15:33:15.121 US/Eastern
>>>>>
>>>>> -- 
>>>>> Ticket URL: <http://plumi.org/ticket/205>
>>>>> Plumi <http://plumi.org/>
>>>>> Plumi - FOSS Video Sharing Platform
>>>>>
>>>>> ------------------------------
>>>>>
>>>>> Message: 2
>>>>> Date: Thu, 04 Dec 2008 04:42:27 -0000
>>>>> From: "Plumi" <trac at plumi.org>
>>>>> Subject: Re: [plumi-discuss] [Plumi] #205: Can't Add or Edit Callouts
>>>>>        - Error on Saving a New Callout or Editing an Existing 
>>>>> Callout (was:
>>>>>        Error on Saving a New Callout or Editing and Existing Callout)
>>>>> Cc: discuss at lists.plumi.org
>>>>> Message-ID: <042.f1a2913629c3f2f4a2b5cdbd591e8b30 at plumi.org>
>>>>> Content-Type: text/plain; charset="utf-8"
>>>>>
>>>>> #205: Can't Add or Edit Callouts - Error on Saving a New Callout 
>>>>> or Editing an
>>>>> Existing Callout
>>>>> -----------------------------+---------------------------------------------- 
>>>>>
>>>>>  Reporter:  anna            |       Owner:  andycat
>>>>>      Type:  defect          |      Status:  new
>>>>>  Priority:  critical        |   Milestone:  0.2.2.1
>>>>>  Component:  SocialSoftware  |     Version:
>>>>> Resolution:                  |    Keywords:
>>>>> -----------------------------+---------------------------------------------- 
>>>>>
>>>>>
>>>>> -- 
>>>>> Ticket URL: <http://www.plumi.org/ticket/205#comment:1>
>>>>> Plumi <http://plumi.org/>
>>>>> Plumi - FOSS Video Sharing Platform
>>>>>
>>>>> ------------------------------
>>>>>
>>>>> _______________________________________________
>>>>> Discuss mailing list
>>>>> Discuss at lists.plumi.org
>>>>> http://lists.plumi.org/listinfo/discuss
>>>>>
>>>>>
>>>>> End of Discuss Digest, Vol 19, Issue 3
>>>>> **************************************
>>>>>
>>>>>     
>>>>
>>>>
>>>>
>>>>   
>>>
>>> _______________________________________________
>>> Discuss mailing list
>>> Discuss at lists.plumi.org
>>> http://lists.plumi.org/listinfo/discuss
>>
>> _______________________________________________
>> Discuss mailing list
>> Discuss at lists.plumi.org
>> http://lists.plumi.org/listinfo/discuss
>
> _______________________________________________
> Discuss mailing list
> Discuss at lists.plumi.org
> http://lists.plumi.org/listinfo/discuss



More information about the Discuss mailing list